#9387882, By The "I've got an iPhone" thread

  • Deleted user 21 February 2013 19:42:02
    Right, I'm having a proper pain-in-the-backside problem. When I moved to the Czech Republic, I bought an iPhone 4S off contract, so I could stick any SIM in it whenever I was back in England visiting, and so I could tether my iPad to it as needed. So, I ended up with an O2 UK SIM for when I'm in the UK, and a Vodafone CZ one for when I'm in Prague.

    So, last week I was back in England for the first time in over a year, used the O2 UK SIM, and everything worked fine once I'd received the activation messages.

    I got back to Prague last Saturday, and put the Vodafone CZ SIM, and since then, my 3G data doesn't work - but only for http (which seems to include iMessages). My emails still work, I still get notifications, but whenever I try and access a web page - or any app tries to - it just times out. Safari eventually gives me a message which says 'Safari cannot open the page. The error was: "There was a problem communicating with the web proxy server (HTTP)."'

    I've tried googling that, but I can't find a single reference, anywhere, to anyone having seen that message when using a 3G connection, only when using wifi. I've set the APN as per Vodafone CZ's instructions on their web page, I've deleted the O2 UK profile from my phone, I've hit the "reset network settings" button, I've tried removing and re-inserting the SIM, I've even updated the phone to the latest version of iOS (just cos it was released since the problem arose), and nothing seems to fix this.

    I've got an outstanding query with Vodafone CZ, but they seem as baffled as I am. So, I thought I'd post here, mainly because I thought the EG hive mind may have encountered this before, but also to warn any fellow multi-national types that, if you use O2 in the UK, those fuckers will (for all intents and purposes) lock your non-contract iphone to their shitty network, the fucking cunts.

    Any suggestions, anybody? The only thing I haven't tried yet is a full wipe and factory reset.
Log in or register to reply